// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*").unwrap();
let string = "Single Line Comment:
# This is a single line comment
Multiple Line Comment:
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}