using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*";
string input = @"Single Line Comment:
# This is a single line comment
Multiple Line Comment:
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}