package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[;#%|*].*(?:(?:\r\n|\r|\n) *[;#%|*].*)*`)
var str = `Single Line Comment:
# This is a single line comment
Multiple Line Comment:
# This is a multiple line comment
# which is just a block of single line comments
# that are strung together
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}