const regex = /^[0-9]{3}\s[0-9]{3}\s[0-9]{4}$|^.[0-9]{2}\s[0-9]{2}\s[0-9]{3}\s[0-9]{4}/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{3}\\s[0-9]{3}\\s[0-9]{4}$|^.[0-9]{2}\\s[0-9]{2}\\s[0-9]{3}\\s[0-9]{4}', 'mg')
const str = `082 689 0343
082 689 0343
+27 82 689 0343
082 689 0343
+23 73 343 0234
0732343234
07 3234 3234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}