use strict;
my $str = '082 689 0343
082 689 0343
+27 82 689 0343
082 689 0343
+23 73 343 0234
0732343234
07 3234 3234';
my $regex = qr/^[0-9]{3}\s[0-9]{3}\s[0-9]{4}$|^.[0-9]{2}\s[0-9]{2}\s[0-9]{3}\s[0-9]{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}