import re
regex = re.compile(r"^[0-9]{3}\s[0-9]{3}\s[0-9]{4}$|^.[0-9]{2}\s[0-9]{2}\s[0-9]{3}\s[0-9]{4}", flags=re.MULTILINE)
test_str = ("082 689 0343\n"
"082 689 0343\n"
"+27 82 689 0343\n"
"082 689 0343\n"
"+23 73 343 0234\n"
"0732343234\n"
"07 3234 3234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")