#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!#).)*something.*$"
Local $sString = "# don't include this something" & @CRLF & _
" # don't include this something either" & @CRLF & _
"### nor this something ###" & @CRLF & _
"something = 1 " & @CRLF & _
" something_else = something + something" & @CRLF & _
"something = 2 # do include this" & @CRLF & _
"another_thing = something + something_else # and this something" & @CRLF & _
"yet_another_thing = 2 # but not this something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")