import re
regex = re.compile(r"^((?!#).)*something.*$", flags=re.MULTILINE)
test_str = ("# don't include this something\n"
" # don't include this something either\n"
"### nor this something ###\n"
"something = 1 \n"
" something_else = something + something\n"
"something = 2 # do include this\n"
"another_thing = something + something_else # and this something\n"
"yet_another_thing = 2 # but not this something")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")