$re = '/^((?!#).)*something.*$/m';
$str = '# don\'t include this something
# don\'t include this something either
### nor this something ###
something = 1
something_else = something + something
something = 2 # do include this
another_thing = something + something_else # and this something
yet_another_thing = 2 # but not this something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);