use strict;
my $str = '# don\'t include this something
# don\'t include this something either
### nor this something ###
something = 1
something_else = something + something
something = 2 # do include this
another_thing = something + something_else # and this something
yet_another_thing = 2 # but not this something';
my $regex = qr/^((?!#).)*something.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}