import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!#).)*something.*$";
final String string = "# don't include this something\n"
+ " # don't include this something either\n"
+ "### nor this something ###\n"
+ "something = 1 \n"
+ " something_else = something + something\n"
+ "something = 2 # do include this\n"
+ "another_thing = something + something_else # and this something\n"
+ "yet_another_thing = 2 # but not this something";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}