const regex = /^((?!#).)*something.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!#).)*something.*$', 'gm')
const str = `# don't include this something
# don't include this something either
### nor this something ###
something = 1
something_else = something + something
something = 2 # do include this
another_thing = something + something_else # and this something
yet_another_thing = 2 # but not this something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}