#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[url(?|=[\'"]?([^]"\']+)[\'"]?](.+)|](([^[]+)))\[/url]"
Local $sString = "[url=http://www.example.com][img]example.jpg[/img][/url]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")