const regex = new RegExp('\\[url(?|=[\\\\'"]?([^]"\\\\']+)[\\\\'"]?](.+)|](([^[]+)))\\[/url]', '')
const str = `[url=http://www.example.com][img]example.jpg[/img][/url]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}