using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[url(?|=[\'""]?([^]""\']+)[\'""]?](.+)|](([^[]+)))\[/url]";
string input = @"[url=http://www.example.com][img]example.jpg[/img][/url]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}