$re = '~\[url(?|=[\'"]?([^]"\']+)[\'"]?](.+)|](([^[]+)))\[/url]~';
$str = '[url=http://www.example.com][img]example.jpg[/img][/url]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);