package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[url(?|=[\'"]?([^]"\']+)[\'"]?](.+)|](([^[]+)))\[/url]`)
var str = `[url=http://www.example.com][img]example.jpg[/img][/url]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}