re = /\[url(?|=[\'"]?([^]"\']+)[\'"]?](.+)|](([^[]+)))\[\/url]/
str = '[url=http://www.example.com][img]example.jpg[/img][/url]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end