import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\/user.?\\s*:(.?\\S*)))";
final String string = " /node:asdf /user:asfsdfd /password:1q2w£1!`\n"
+ "/node:asdf /user:asfsdfd /password:1q2w£1!` \n"
+ " /user:asfsdfd /node:asdf /password:1q2w£1!` \n"
+ "/password:1q2w£1!` /user:asfsdfd /node:asdf \n"
+ "/password:1q2w£1!` /user:asfsdfd /node:asdf \n"
+ "/password:1q2w£1!` /user :asfsdfd /node :asdf \n"
+ " /password :1q2w£1!` /user: asfsdfd /node : asdf \n"
+ "/password:1q2w£1!` /user: asfsdfd /node : asdf \n"
+ "/password:1q2w£1!` /user : \"asfsdfd /node : asdf \n"
+ " /node:\"hostb\" /user :\"administrator\" /password:\"quick-radio-cat-88\"\n"
+ " /user :\"administrator\" /node:\"hostb\" /password:\"quick-radio-cat-88\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}