import Foundation
let pattern = #"(?:(?:\/user.?\s*:(.?\S*)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/node:asdf /user:asfsdfd /password:1q2w£1!`
/node:asdf /user:asfsdfd /password:1q2w£1!`
/user:asfsdfd /node:asdf /password:1q2w£1!`
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user :asfsdfd /node :asdf
/password :1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user : "asfsdfd /node : asdf
/node:"hostb" /user :"administrator" /password:"quick-radio-cat-88"
/user :"administrator" /node:"hostb" /password:"quick-radio-cat-88"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)