using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=[(,])|(?<=\( ))aa(?=[),]| \))";
string input = @"(aa)
The anomalous assignment ( aa)
The anomalous assignment ( aa )
Try to push the handles ( aa,bb) and press on them (aa, bb).
The aa is big
aa,bb are handles
To rescue tyou car call (aaa)
The code is (aabbcc) (aa bb)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}