import re
regex = re.compile(r"(?:(?<=[(,])|(?<=\( ))aa(?=[),]| \))", flags=re.MULTILINE)
test_str = ("(aa)\n"
"The anomalous assignment ( aa)\n"
"The anomalous assignment ( aa )\n"
"Try to push the handles ( aa,bb) and press on them (aa, bb).\n\n"
"The aa is big\n"
"aa,bb are handles\n"
"To rescue tyou car call (aaa)\n"
"The code is (aabbcc) (aa bb)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")