use strict;
my $str = '(aa)
The anomalous assignment ( aa)
The anomalous assignment ( aa )
Try to push the handles ( aa,bb) and press on them (aa, bb).
The aa is big
aa,bb are handles
To rescue tyou car call (aaa)
The code is (aabbcc) (aa bb)';
my $regex = qr/(?:(?<=[(,])|(?<=\( ))aa(?=[),]| \))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}