$re = '/(?:(?<=[(,])|(?<=\( ))aa(?=[),]| \))/m';
$str = '(aa)
The anomalous assignment ( aa)
The anomalous assignment ( aa )
Try to push the handles ( aa,bb) and press on them (aa, bb).
The aa is big
aa,bb are handles
To rescue tyou car call (aaa)
The code is (aabbcc) (aa bb)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);