import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=[(,])|(?<=\\( ))aa(?=[),]| \\))";
final String string = "(aa)\n"
+ "The anomalous assignment ( aa)\n"
+ "The anomalous assignment ( aa )\n"
+ "Try to push the handles ( aa,bb) and press on them (aa, bb).\n\n"
+ "The aa is big\n"
+ "aa,bb are handles\n"
+ "To rescue tyou car call (aaa)\n"
+ "The code is (aabbcc) (aa bb)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}