import Foundation
let pattern = #"(?:(?<=[(,])|(?<=\( ))aa(?=[),]| \))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(aa)
The anomalous assignment ( aa)
The anomalous assignment ( aa )
Try to push the handles ( aa,bb) and press on them (aa, bb).
The aa is big
aa,bb are handles
To rescue tyou car call (aaa)
The code is (aabbcc) (aa bb)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)