# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\{)\{\{(?:([^{}]+)|\{([^{}]+)})}}(?!})//gm;t' <<< "{{example}}
{{{example2}}}
{{example3}}}
{example4}
{{{example5}}
{{{{example6}}}}
{{ example7 }} some other words {{{example8}}}
{{{example9}}} some other words {{example10}} {{example11}}
words"