$re = '/(?<!\{)\{\{(?:([^{}]+)|\{([^{}]+)})}}(?!})/m';
$str = '{{example}}
{{{example2}}}
{{example3}}}
{example4}
{{{example5}}
{{{{example6}}}}
{{ example7 }} some other words {{{example8}}}
{{{example9}}} some other words {{example10}} {{example11}}
words';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;