import re
regex = re.compile(r"(?<!\{)\{\{(?:([^{}]+)|\{([^{}]+)})}}(?!})", flags=re.MULTILINE)
test_str = ("{{example}}\n"
"{{{example2}}}\n"
"{{example3}}}\n"
"{example4}\n"
"{{{example5}}\n"
"{{{{example6}}}}\n"
"{{ example7 }} some other words {{{example8}}}\n"
"{{{example9}}} some other words {{example10}} {{example11}}\n"
"words")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)