import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\{)\\{\\{(?:([^\\{\\}]+)|\\{([^\\{\\}]+)\\})\\}\\}(?!\\})";
final String string = "{{example}}\n"
+ "{{{example2}}}\n"
+ "{{example3}}}\n"
+ "{example4}\n"
+ "{{{example5}}\n"
+ "{{{{example6}}}}\n"
+ "{{ example7 }} some other words {{{example8}}}\n"
+ "{{{example9}}} some other words {{example10}} {{example11}}\n"
+ "words";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}