#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\{)\{\{(?:([^{}]+)|\{([^{}]+)})}}(?!})"
Local $sString = "{{example}}" & @CRLF & _
"{{{example2}}}" & @CRLF & _
"{{example3}}}" & @CRLF & _
"{example4}" & @CRLF & _
"{{{example5}}" & @CRLF & _
"{{{{example6}}}}" & @CRLF & _
"{{ example7 }} some other words {{{example8}}}" & @CRLF & _
"{{{example9}}} some other words {{example10}} {{example11}}" & @CRLF & _
"words"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)