using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\{)\{\{(?:([^{}]+)|\{([^{}]+)})}}(?!})";
string substitution = @"";
string input = @"{{example}}
{{{example2}}}
{{example3}}}
{example4}
{{{example5}}
{{{{example6}}}}
{{ example7 }} some other words {{{example8}}}
{{{example9}}} some other words {{example10}} {{example11}}
words";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}