using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\S+\s+\S+\s+(?<number_extract>\d+)";
string input = @"3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}