package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+\s+\S+\s+(?<number_extract>\d+)`)
var str = `3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}