const regex = new RegExp('^\\S+\\s+\\S+\\s+(?<number_extract>\\d+)', 'gm')
const str = `3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}