re = /^\S+\s+\S+\s+(?<number_extract>\d+)/m
str = '3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end