// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\S+\s+\S+\s+(?<number_extract>\d+)").unwrap();
let string = "3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}