$re = '@^\S+\s+\S+\s+(?<number_extract>\d+)@m';
$str = '3/03/0 EE 14 GFR 20 AAA XXXXX 50 3365.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);