#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d*\.?\d+|\d{1,3}(?:,\d{3})*(?:\.\d+)?)$"
Local $sString = "1" & @CRLF & _
"0" & @CRLF & _
"01" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"100.1" & @CRLF & _
"1000.123" & @CRLF & _
"012.21" & @CRLF & _
"0.123" & @CRLF & _
"1002.42" & @CRLF & _
"1232.0" & @CRLF & _
"1,232" & @CRLF & _
"1,232.0" & @CRLF & _
"130,232,251.0" & @CRLF & _
"1.00" & @CRLF & _
"1.000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")