import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d*\\.?\\d+|\\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?)$";
final String string = "1\n"
+ "0\n"
+ "01\n"
+ "10\n"
+ "100\n"
+ "100.1\n"
+ "1000.123\n"
+ "012.21\n"
+ "0.123\n"
+ "1002.42\n"
+ "1232.0\n"
+ "1,232\n"
+ "1,232.0\n"
+ "130,232,251.0\n"
+ "1.00\n"
+ "1.000\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}