const regex = /^(\d*\.?\d+|\d{1,3}(?:,\d{3})*(?:\.\d+)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*\\.?\\d+|\\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?)$', 'gm')
const str = `1
0
01
10
100
100.1
1000.123
012.21
0.123
1002.42
1232.0
1,232
1,232.0
130,232,251.0
1.00
1.000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}