package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*\.?\d+|\d{1,3}(?:,\d{3})*(?:\.\d+)?)$`)
var str = `1
0
01
10
100
100.1
1000.123
012.21
0.123
1002.42
1232.0
1,232
1,232.0
130,232,251.0
1.00
1.000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}