// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d*\.?\d+|\d{1,3}(?:,\d{3})*(?:\.\d+)?)$").unwrap();
let string = "1
0
01
10
100
100.1
1000.123
012.21
0.123
1002.42
1232.0
1,232
1,232.0
130,232,251.0
1.00
1.000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}