use strict;
my $str = '1
0
01
10
100
100.1
1000.123
012.21
0.123
1002.42
1232.0
1,232
1,232.0
130,232,251.0
1.00
1.000
';
my $regex = qr/^(\d*\.?\d+|\d{1,3}(?:,\d{3})*(?:\.\d+)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}