# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[^;\n\r\t])"(?=[^;\n\r\t])//g;t' <<< "\"ModifTextePub\";\"ModifObservation\";\"Resume\"Vitrine\";\"Observations\"Criteres\"\";\"InternetOK\";\"NumPhoto\";\"AmianteLe\";\"SNavantLe\";\"ActePrec\";\"ProprietairesPrec\";\"Situation\";\"FraisNotaires\""