import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[^;\\n\\r\\t])\"(?=[^;\\n\\r\\t])";
final String string = "\"ModifTextePub\";\"ModifObservation\";\"Resume\"Vitrine\";\"Observations\"Criteres\"\";\"InternetOK\";\"NumPhoto\";\"AmianteLe\";\"SNavantLe\";\"ActePrec\";\"ProprietairesPrec\";\"Situation\";\"FraisNotaires\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}