const regex = /(?<=[^;\n\r\t])"(?=[^;\n\r\t])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^;\\n\\r\\t])"(?=[^;\\n\\r\\t])', 'g')
const str = `"ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);