import re
regex = re.compile(r"(?<=[^;\n\r\t])\"(?=[^;\n\r\t])")
test_str = "\"ModifTextePub\";\"ModifObservation\";\"Resume\"Vitrine\";\"Observations\"Criteres\"\";\"InternetOK\";\"NumPhoto\";\"AmianteLe\";\"SNavantLe\";\"ActePrec\";\"ProprietairesPrec\";\"Situation\";\"FraisNotaires\""
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)