#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(<\/?place-holder_(10|\d)>))"
Local $sString = " <consumers>" & @CRLF & _
" <place-holder_1>" & @CRLF & _
" <consumer>" & @CRLF & _
" <val>1</val>" & @CRLF & _
" </consumer>" & @CRLF & _
" </place-holder_1>" & @CRLF & _
" <place-holder_2>" & @CRLF & _
" <consumer-info>" & @CRLF & _
" <val>2</val>" & @CRLF & _
" </consumer-info>" & @CRLF & _
" </place-holder_2>" & @CRLF & _
" <place-holder_10>" & @CRLF & _
" <consumer-info>" & @CRLF & _
" <val>2</val>" & @CRLF & _
" </consumer-info>" & @CRLF & _
" </place-holder_10>" & @CRLF & _
" </consumers>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")