const regex = /(?=(<\/?place-holder_(10|\d)>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(<\\\/?place-holder_(10|\\d)>))', 'g')
const str = ` <consumers>
<place-holder_1>
<consumer>
<val>1</val>
</consumer>
</place-holder_1>
<place-holder_2>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_2>
<place-holder_10>
<consumer-info>
<val>2</val>
</consumer-info>
</place-holder_10>
</consumers>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}